about summary refs log tree commit diff
path: root/tvix/default.nix
diff options
context:
space:
mode:
authorsterni <sternenseemann@systemli.org>2024-03-10T20·59+0100
committerclbot <clbot@tvl.fyi>2024-03-17T10·56+0000
commite220d807270e9967d7b76070b968981c2c3dda0c (patch)
tree6f03daacaf111fbb76d0de248f922046dc513c49 /tvix/default.nix
parent32c56749623dea3f7076b3f4d7952e36449e4fde (diff)
chore(3p/sources): Bump channels & overlays r/7717
- agenix has not been updated (https://github.com/ryantm/agenix/pull/241).

- //tvix: regenerate protobuf files

- //tvix:clippy: work around https://github.com/rust-lang/rust-clippy/issues/12281
  which exclusively causes false positives in our code at the moment.

Change-Id: I38d2f4c0e6d1abc92be360b06f58e6d40e7732a3
Reviewed-on: https://cl.tvl.fyi/c/depot/+/11127
Reviewed-by: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Autosubmit: sterni <sternenseemann@systemli.org>
Reviewed-by: tazjin <tazjin@tvl.su>
Diffstat (limited to 'tvix/default.nix')
-rw-r--r--tvix/default.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/tvix/default.nix b/tvix/default.nix
index e34e5e3164..da3e0ca605 100644
--- a/tvix/default.nix
+++ b/tvix/default.nix
@@ -220,7 +220,9 @@ in
       rustPlatform.cargoSetupHook
     ];
 
-    buildPhase = "cargo clippy --tests --all-features --benches --examples -- -Dwarnings | tee $out";
+    # Allow blocks_in_conditions due to false positives with #[tracing::instrument(…)]:
+    # https://github.com/rust-lang/rust-clippy/issues/12281
+    buildPhase = "cargo clippy --tests --all-features --benches --examples -- -Dwarnings -A clippy::blocks_in_conditions | tee $out";
   };
 
   meta.ci.targets = [