about summary refs log tree commit diff
path: root/tvix/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-09-17T11·14+0300
committerflokli <flokli@flokli.de>2023-09-17T13·14+0000
commit683d3e0d2d1de30eb7895861627203e62702a770 (patch)
treed14fb1d95285ca08e226e4bb05c5a137dfa5bde2 /tvix/Cargo.toml
parent51b8571c48168435c892cb58e9ad62f7c979e4d5 (diff)
chore(tvix): upgrade workspace.resolver to "2" r/6599
This shuts off the following warning:

```
warning: some crates are on edition 2021 which defaults to `resolver = "2"`, but virtual workspaces default to `resolver = "1"`
note: to keep the current resolver, specify `workspace.resolver = "1"` in the workspace root's manifest
note: to use the edition 2021 resolver, specify `workspace.resolver = "2"` in the workspace root's manifest
```

Stuff still seems to work with it, so no need to stick with "1".

See https://doc.rust-lang.org/edition-guide/rust-2021/default-cargo-resolver.html
for more details.

Change-Id: I6056d95cd5cb793f37ef843ed43009a27ad36367
Reviewed-on: https://cl.tvl.fyi/c/depot/+/9342
Reviewed-by: raitobezarius <tvl@lahfa.xyz>
Reviewed-by: Connor Brewster <cbrewster@hey.com>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/Cargo.toml')
-rw-r--r--tvix/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/tvix/Cargo.toml b/tvix/Cargo.toml
index 314e329e6f..938364fc26 100644
--- a/tvix/Cargo.toml
+++ b/tvix/Cargo.toml
@@ -16,6 +16,7 @@
 # extra steps or other auxiliary targets.
 
 [workspace]
+resolver = "2"
 
 members = [
   "cli",