about summary refs log tree commit diff
path: root/tvix/Cargo.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-09-26T07·30+0300
committerclbot <clbot@tvl.fyi>2023-09-26T10·07+0000
commit6b02800e486a46e28d6bec79ba3ba94fe006e8c5 (patch)
treec4618647fcae77581956a065d5809f3186e386ad /tvix/Cargo.nix
parent329067f62954f09bcaf87a016f4211fdcf9789dd (diff)
chore(tvix/[ca]store): allow building without tonic-reflection r/6660
 - rename the feature to `tonic-reflection` in both tvix-store and tvix-
   castore.
 - set it to disabled in tvix-castore by default
 - enable it in tvix-store, and pull in tvix-castore with the feature
   enabled.

Change-Id: Ie22833d85569502cae55812f6eeb17a9c15b9e2c
Reviewed-on: https://cl.tvl.fyi/c/depot/+/9472
Autosubmit: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Reviewed-by: raitobezarius <tvl@lahfa.xyz>
Diffstat (limited to 'tvix/Cargo.nix')
-rw-r--r--tvix/Cargo.nix11
1 files changed, 4 insertions, 7 deletions
diff --git a/tvix/Cargo.nix b/tvix/Cargo.nix
index 130a89a1ae..356c1e9929 100644
--- a/tvix/Cargo.nix
+++ b/tvix/Cargo.nix
@@ -8405,11 +8405,9 @@ rec {
           }
         ];
         features = {
-          "default" = [ "reflection" ];
-          "reflection" = [ "tonic-reflection" ];
           "tonic-reflection" = [ "dep:tonic-reflection" ];
         };
-        resolvedDefaultFeatures = [ "default" "reflection" "tonic-reflection" ];
+        resolvedDefaultFeatures = [ "default" "tonic-reflection" ];
       };
       "tvix-cli" = rec {
         crateName = "tvix-cli";
@@ -8882,14 +8880,13 @@ rec {
           }
         ];
         features = {
-          "default" = [ "fuse" "virtiofs" "reflection" ];
+          "default" = [ "fuse" "virtiofs" "tonic-reflection" ];
           "fs" = [ "dep:libc" "dep:fuse-backend-rs" ];
           "fuse" = [ "fs" ];
-          "reflection" = [ "tonic-reflection" ];
-          "tonic-reflection" = [ "dep:tonic-reflection" ];
+          "tonic-reflection" = [ "dep:tonic-reflection" "tvix-castore/tonic-reflection" ];
           "virtiofs" = [ "fs" "dep:vhost" "dep:vhost-user-backend" "dep:virtio-queue" "dep:vm-memory" "dep:vmm-sys-util" "dep:virtio-bindings" "fuse-backend-rs?/vhost-user-fs" "fuse-backend-rs?/virtiofs" ];
         };
-        resolvedDefaultFeatures = [ "default" "fs" "fuse" "reflection" "tonic-reflection" "virtiofs" ];
+        resolvedDefaultFeatures = [ "default" "fs" "fuse" "tonic-reflection" "virtiofs" ];
       };
       "typenum" = rec {
         crateName = "typenum";