about summary refs log tree commit diff
path: root/tvix/Cargo.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2024-02-20T05·12+0700
committerflokli <flokli@flokli.de>2024-02-20T05·29+0000
commit43570bae11ff5c5fac5c644785a7c372367826ba (patch)
tree0119a2f858c978a54e521d84bdc37963540b932d /tvix/Cargo.nix
parent98a17dbdf9f6756b5162d34eda17098918e991cf (diff)
refactor(tvix/store/proto): use bstr::ByteSlice r/7566
String::from_utf8_lossy simply discards invalid bytes, while bstr
replaces them with their replacement character.

Change-Id: Ib78ff36ca5faacc1ad60bc4ddde7b62773848c07
Reviewed-on: https://cl.tvl.fyi/c/depot/+/10981
Tested-by: BuildkiteCI
Reviewed-by: Peter Kolloch <info@eigenvalue.net>
Reviewed-by: flokli <flokli@flokli.de>
Diffstat (limited to 'tvix/Cargo.nix')
-rw-r--r--tvix/Cargo.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/tvix/Cargo.nix b/tvix/Cargo.nix
index a39c8ef38d..f12d955061 100644
--- a/tvix/Cargo.nix
+++ b/tvix/Cargo.nix
@@ -10789,6 +10789,10 @@ rec {
             features = [ "rayon" "std" ];
           }
           {
+            name = "bstr";
+            packageId = "bstr";
+          }
+          {
             name = "bytes";
             packageId = "bytes";
           }