about summary refs log tree commit diff
path: root/tvix/Cargo.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-02-13T15·47+0100
committerflokli <flokli@flokli.de>2023-03-10T10·58+0000
commit419f7d0f0c3dadeb0bbecda763aaec73ed8da8dd (patch)
tree0559440c1b67c5aa958e883439abb299b4fdb8e3 /tvix/Cargo.nix
parentab02fc668c23a4f0f262dd889278f2fc36793f9e (diff)
feat(tvix/store): add NARCalculationService trait and impl r/5918
This adds a NARCalculationService trait, which will take a root node,
and provide a proto::CalculateNarResponse in return.

It also adds a NonCachingNARCalculationService implementation, that will
simply always render the NAR in memory to calculate the size and sha256,
without any caching.

Change-Id: Id1ffb18559212fa6001f70f2634bbc3dfd0aa343
Reviewed-on: https://cl.tvl.fyi/c/depot/+/8096
Reviewed-by: raitobezarius <tvl@lahfa.xyz>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/Cargo.nix')
-rw-r--r--tvix/Cargo.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/tvix/Cargo.nix b/tvix/Cargo.nix
index 126edecdff..fc3f945df3 100644
--- a/tvix/Cargo.nix
+++ b/tvix/Cargo.nix
@@ -1246,6 +1246,21 @@ rec {
         ];
 
       };
+      "count-write" = rec {
+        crateName = "count-write";
+        version = "0.1.0";
+        edition = "2018";
+        sha256 = "11bswmgr81s3jagdci1pr6qh9vnz9zsbbf2dqpi260daa2mhgmff";
+        authors = [
+          "SOFe <sofe2038@gmail.com>"
+        ];
+        features = {
+          "futures" = [ "futures-io-preview" ];
+          "futures-io-preview" = [ "dep:futures-io-preview" ];
+          "tokio" = [ "tokio-io" ];
+          "tokio-io" = [ "dep:tokio-io" ];
+        };
+      };
       "countme" = rec {
         crateName = "countme";
         version = "3.0.1";
@@ -8253,6 +8268,10 @@ rec {
             features = [ "derive" "env" ];
           }
           {
+            name = "count-write";
+            packageId = "count-write";
+          }
+          {
             name = "data-encoding";
             packageId = "data-encoding";
           }
@@ -8273,6 +8292,10 @@ rec {
             packageId = "prost";
           }
           {
+            name = "sha2";
+            packageId = "sha2 0.10.6";
+          }
+          {
             name = "sled";
             packageId = "sled";
             features = [ "compression" ];