about summary refs log tree commit diff
path: root/tvix/Cargo.toml
diff options
context:
space:
mode:
authoredef <edef@edef.eu>2023-11-19T05·23+0000
committeredef <edef@edef.eu>2023-11-19T08·35+0000
commit9ad7cc629e20e4cdb5420e20addae8909e83d610 (patch)
treecb32166c7b2201eedea5d9c8109860d7788070a0 /tvix/Cargo.toml
parent479f26f46cf8a5301c6ad541ceee73fe95239c8d (diff)
fix(tvix): patch futures::AsyncBufReadExt::fill_buf r/7032
This fixes EOF handling for buffered readers.

Link: https://github.com/rust-lang/futures-rs/pull/2801
Change-Id: Ie98ca6a3e1de38500b0195e9b62511501acb1d2c
Reviewed-on: https://cl.tvl.fyi/c/depot/+/10086
Reviewed-by: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/Cargo.toml')
-rw-r--r--tvix/Cargo.toml11
1 files changed, 11 insertions, 0 deletions
diff --git a/tvix/Cargo.toml b/tvix/Cargo.toml
index 23486a921b..167e0aa2e2 100644
--- a/tvix/Cargo.toml
+++ b/tvix/Cargo.toml
@@ -36,3 +36,14 @@ members = [
 [profile.release-with-debug]
 inherits = "release"
 debug = true
+
+[patch.crates-io]
+# https://github.com/rust-lang/futures-rs/pull/2801
+futures-channel = { git = "https://github.com/edef1c/futures-rs", rev = "23e25061f2261794d6d611675a6372c96b70fa85" }
+futures-core = { git = "https://github.com/edef1c/futures-rs", rev = "23e25061f2261794d6d611675a6372c96b70fa85" }
+futures-executor = { git = "https://github.com/edef1c/futures-rs", rev = "23e25061f2261794d6d611675a6372c96b70fa85" }
+futures-io = { git = "https://github.com/edef1c/futures-rs", rev = "23e25061f2261794d6d611675a6372c96b70fa85" }
+futures-macro = { git = "https://github.com/edef1c/futures-rs", rev = "23e25061f2261794d6d611675a6372c96b70fa85" }
+futures-sink = { git = "https://github.com/edef1c/futures-rs", rev = "23e25061f2261794d6d611675a6372c96b70fa85" }
+futures-task = { git = "https://github.com/edef1c/futures-rs", rev = "23e25061f2261794d6d611675a6372c96b70fa85" }
+futures-util = { git = "https://github.com/edef1c/futures-rs", rev = "23e25061f2261794d6d611675a6372c96b70fa85" }