about summary refs log tree commit diff
path: root/tools/depotfmt.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@tvl.su>2023-10-29T10·24+0300
committerclbot <clbot@tvl.fyi>2023-10-30T16·33+0000
commit67fed3d76deae9eb62f0313812c56e93e595cb3a (patch)
tree6bb8398da01ce4829778f7f392025e27182be6c3 /tools/depotfmt.nix
parentc37c9cc77037dc511ea7683ea8e80795e3b9188f (diff)
chore(tools/depotfmt): use Go version from buildGo r/6915
This is required because Go 1.18 is actually being deleted. I've
applied the formatting breakage that it introduces (such as breaking
comment formatting), because I can't be bothered to try and work
around broken Go stuff.

Change-Id: Ica7cee0d01228845d6a766079fef36df99a3da96
Reviewed-on: https://cl.tvl.fyi/c/depot/+/9832
Autosubmit: tazjin <tazjin@tvl.su>
Reviewed-by: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Diffstat (limited to 'tools/depotfmt.nix')
-rw-r--r--tools/depotfmt.nix3
1 files changed, 1 insertions, 2 deletions
diff --git a/tools/depotfmt.nix b/tools/depotfmt.nix
index 4530469d1c..f493a42e59 100644
--- a/tools/depotfmt.nix
+++ b/tools/depotfmt.nix
@@ -9,10 +9,9 @@ let
     echo "$@" | xargs -n1 ${pkgs.terraform}/bin/terraform fmt
   '';
 
-  # TODO: Upgrade to Go 1.19 and reformat tree
   config = pkgs.writeText "depot-treefmt-config" ''
     [formatter.go]
-    command = "${pkgs.go_1_18}/bin/gofmt"
+    command = "${depot.nix.buildGo.go}/bin/gofmt"
     options = [ "-w" ]
     includes = ["*.go"]