about summary refs log tree commit diff
path: root/users/picnoir/tvix-daemon/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'users/picnoir/tvix-daemon/Cargo.toml')
-rw-r--r--users/picnoir/tvix-daemon/Cargo.toml17
1 files changed, 17 insertions, 0 deletions
diff --git a/users/picnoir/tvix-daemon/Cargo.toml b/users/picnoir/tvix-daemon/Cargo.toml
new file mode 100644
index 0000000000..f0642dbd53
--- /dev/null
+++ b/users/picnoir/tvix-daemon/Cargo.toml
@@ -0,0 +1,17 @@
+[package]
+name = "tvix-daemon"
+version = "0.1.0"
+edition = "2021"
+
+[dependencies]
+tvix-store = { path = "../../../tvix/store/" }
+nix-compat = { path = "../../../tvix/nix-compat/" }
+tokio-listener = "0.3.1"
+tokio = { version = "1.36.0", features = ["full"] }
+tracing-subscriber = "0.3.18"
+tracing = "0.1.40"
+anyhow = "1.0.81"
+clap = { version = "4.5.3", features = ["derive"] }
+
+[dev-dependencies]
+tokio-test = "0.4.4"