about summary refs log tree commit diff
path: root/users/picnoir/tvix-daemon/Cargo.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/picnoir/tvix-daemon/Cargo.nix')
-rw-r--r--users/picnoir/tvix-daemon/Cargo.nix33
1 files changed, 2 insertions, 31 deletions
diff --git a/users/picnoir/tvix-daemon/Cargo.nix b/users/picnoir/tvix-daemon/Cargo.nix
index aa3faf4a89..8dc9b54175 100644
--- a/users/picnoir/tvix-daemon/Cargo.nix
+++ b/users/picnoir/tvix-daemon/Cargo.nix
@@ -1,5 +1,5 @@
-# This file was @generated by crate2nix 0.13.0 with the command:
-#   "generate" "--all-features"
+# This file was @generated by crate2nix 0.12.0 with the command:
+#   "generate"
 # See https://github.com/kolloch/crate2nix for more info.
 
 { nixpkgs ? <nixpkgs>
@@ -229,20 +229,6 @@ rec {
         ];
 
       };
-      "anyhow" = rec {
-        crateName = "anyhow";
-        version = "1.0.81";
-        edition = "2018";
-        sha256 = "0ivj2k7vajai9hc11lhjp73n6rqs1ykg6wbjjjl1mz9adj580lh9";
-        authors = [
-          "David Tolnay <dtolnay@gmail.com>"
-        ];
-        features = {
-          "backtrace" = [ "dep:backtrace" ];
-          "default" = [ "std" ];
-        };
-        resolvedDefaultFeatures = [ "default" "std" ];
-      };
       "async-stream" = rec {
         crateName = "async-stream";
         version = "0.3.5";
@@ -4160,10 +4146,6 @@ rec {
           else ./.;
         dependencies = [
           {
-            name = "anyhow";
-            packageId = "anyhow";
-          }
-          {
             name = "clap";
             packageId = "clap";
             features = [ "derive" "env" ];
@@ -5211,7 +5193,6 @@ rec {
               (
                 _: {
                   buildTests = true;
-                  release = false;
                 }
               );
             # If the user hasn't set any pre/post commands, we don't want to
@@ -5236,16 +5217,6 @@ rec {
             # recreate a file hierarchy as when running tests with cargo
 
             # the source for test data
-            # It's necessary to locate the source in $NIX_BUILD_TOP/source/
-            # instead of $NIX_BUILD_TOP/
-            # because we compiled those test binaries in the former and not the latter.
-            # So all paths will expect source tree to be there and not in the build top directly.
-            # For example: $NIX_BUILD_TOP := /build in general, if you ask yourself.
-            # TODO(raitobezarius): I believe there could be more edge cases if `crate.sourceRoot`
-            # do exist but it's very hard to reason about them, so let's wait until the first bug report.
-            mkdir -p source/
-            cd source/
-
             ${pkgs.buildPackages.xorg.lndir}/bin/lndir ${crate.src}
 
             # build outputs