about summary refs log tree commit diff
path: root/third_party/lisp/cl-json.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/cl-json.nix')
-rw-r--r--third_party/lisp/cl-json.nix18
1 files changed, 10 insertions, 8 deletions
diff --git a/third_party/lisp/cl-json.nix b/third_party/lisp/cl-json.nix
index 3652bd0793..5d1450a3e9 100644
--- a/third_party/lisp/cl-json.nix
+++ b/third_party/lisp/cl-json.nix
@@ -1,13 +1,15 @@
 # JSON encoder & decoder
-{ depot, ... }:
+{ depot, pkgs, ... }:
 
-with depot.nix;
-let src = depot.third_party.fetchFromGitHub {
-  owner = "hankhero";
-  repo = "cl-json";
-  rev = "6dfebb9540bfc3cc33582d0c03c9ec27cb913e79";
-  sha256 = "0fx3m3x3s5ji950yzpazz4s0img3l6b3d6l3jrfjv0lr702496lh";
-};
+let
+  inherit (depot.nix) buildLisp;
+
+  src = pkgs.fetchFromGitHub {
+    owner = "hankhero";
+    repo = "cl-json";
+    rev = "6dfebb9540bfc3cc33582d0c03c9ec27cb913e79";
+    sha256 = "0fx3m3x3s5ji950yzpazz4s0img3l6b3d6l3jrfjv0lr702496lh";
+  };
 in buildLisp.library {
   name = "cl-json";
   deps = [ (buildLisp.bundled "asdf") ];