about summary refs log tree commit diff
path: root/users/picnoir/tvix-daemon/shell.nix
diff options
context:
space:
mode:
authorPicnoir <picnoir@alternativebit.fr>2024-03-19T13·34+0100
committerpicnoir picnoir <picnoir@alternativebit.fr>2024-03-19T16·51+0000
commit29b5ffbda042650640ac6d8b23b20fb44897ed62 (patch)
treeab283c8c1c5e3896992038bd7c64744e3ce0bf78 /users/picnoir/tvix-daemon/shell.nix
parent09e5f1782ca7da085ffc58654be51e73160968c8 (diff)
feat(users/picnoir/tvix-daemon): introduce tvix-daemon r/7742
This daemon is a re-implementation of the Nix daemon except it uses
tvix-store as a remote store.

For now, it's very barebones, this is just a quick and dirty setup to
get started with the project. We bind to the unix socket provided by
systemd, wait for cpp Nix to send the magic hello bytes, respond with
the magic hello bytes and call it a day.

Storing this under my username for now, the project is mostly
irrelevant as it is. We'll move it to Tvix if it gets complete and
relevant at some point.

Change-Id: Ifc5dce2df37413504f9de1942c5b7d425eddf759
Reviewed-on: https://cl.tvl.fyi/c/depot/+/11198
Reviewed-by: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Diffstat (limited to 'users/picnoir/tvix-daemon/shell.nix')
-rw-r--r--users/picnoir/tvix-daemon/shell.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/users/picnoir/tvix-daemon/shell.nix b/users/picnoir/tvix-daemon/shell.nix
new file mode 100644
index 0000000000..6ec6b961fa
--- /dev/null
+++ b/users/picnoir/tvix-daemon/shell.nix
@@ -0,0 +1,21 @@
+{ pkgs, ... }:
+pkgs.mkShell {
+  name = "tvix-daemon";
+  packages = [
+    pkgs.cargo
+    pkgs.cargo-machete
+    pkgs.cargo-expand
+    pkgs.clippy
+    pkgs.evans
+    pkgs.fuse
+    pkgs.go
+    pkgs.grpcurl
+    pkgs.hyperfine
+    pkgs.nix_2_3 # b/313
+    pkgs.pkg-config
+    pkgs.rust-analyzer
+    pkgs.rustc
+    pkgs.rustfmt
+    pkgs.protobuf
+  ];
+}