about summary refs log tree commit diff
path: root/tvix/nix-compat/Cargo.toml
diff options
context:
space:
mode:
authoredef <edef@edef.eu>2023-10-27T10·54+0000
committeredef <edef@edef.eu>2023-10-27T16·08+0000
commit9253bf6632b17e68417b0cde29609cafa6225cee (patch)
treeaad4aca03b81f7001157930f24430d7c7637f107 /tvix/nix-compat/Cargo.toml
parentb1ad94cc9a638846de5e2c5b08dbc999b49d11b9 (diff)
feat(tvix/nix-compat): add narinfo parsing and serialisation r/6897
Change-Id: I72c63414794642ca8d85c3f635f49db888420c40
Reviewed-on: https://cl.tvl.fyi/c/depot/+/9852
Reviewed-by: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/nix-compat/Cargo.toml')
-rw-r--r--tvix/nix-compat/Cargo.toml6
1 files changed, 6 insertions, 0 deletions
diff --git a/tvix/nix-compat/Cargo.toml b/tvix/nix-compat/Cargo.toml
index cc6dfe5ebc..7a51d14e27 100644
--- a/tvix/nix-compat/Cargo.toml
+++ b/tvix/nix-compat/Cargo.toml
@@ -26,6 +26,8 @@ serde_json = "1.0"
 test-case = "2.2.2"
 criterion = { version = "0.4", features = ["html_reports"] }
 hex-literal = "0.4.1"
+pretty_assertions = "1.4.0"
+zstd = "^0.9.0"
 
 [dev-dependencies.test-generator]
 # This fork of test-generator adds support for cargo workspaces, see
@@ -36,3 +38,7 @@ rev = "82e799979980962aec1aa324ec6e0e4cad781f41"
 [[bench]]
 name = "derivation_parse_aterm"
 harness = false
+
+[[bench]]
+name = "narinfo_parse"
+harness = false