about summary refs log tree commit diff
path: root/tvix/nix-compat/Cargo.toml
diff options
context:
space:
mode:
authoredef <edef@edef.eu>2023-10-09T21·06+0000
committerclbot <clbot@tvl.fyi>2023-10-10T17·13+0000
commit8b35d97b4b4b166f89537634661990e3bcc9755a (patch)
treecb663dc26dc7dae667575e9299981eb688a8c0c1 /tvix/nix-compat/Cargo.toml
parentf38290cfb052c017c58247f64b6875fb6c31c0c0 (diff)
feat(tvix/nix-compat): add nar::writer::async r/6768
Change-Id: Ib962f889836659fd278beec461ee329b00e64ea5
Reviewed-on: https://cl.tvl.fyi/c/depot/+/9615
Autosubmit: edef <edef@edef.eu>
Reviewed-by: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/nix-compat/Cargo.toml')
-rw-r--r--tvix/nix-compat/Cargo.toml5
1 files changed, 5 insertions, 0 deletions
diff --git a/tvix/nix-compat/Cargo.toml b/tvix/nix-compat/Cargo.toml
index 89aae3d4fa..3820ed6b1f 100644
--- a/tvix/nix-compat/Cargo.toml
+++ b/tvix/nix-compat/Cargo.toml
@@ -5,15 +5,20 @@ edition = "2021"
 
 # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
 
+[features]
+async = ["futures-util"]
+
 [dependencies]
 bstr = { version = "1.6.0", features = ["alloc", "unicode", "serde"] }
 data-encoding = "2.3.3"
+futures-util = { version = "0.3.28", features = ["io"], optional = true }
 serde = { version = "1.0", features = ["derive"] }
 serde_json = "1.0"
 sha2 = "0.10.6"
 thiserror = "1.0.38"
 
 [dev-dependencies]
+futures = { version = "0.3.28", default-features = false, features = ["executor"] }
 serde_json = "1.0"
 test-case = "2.2.2"