about summary refs log tree commit diff
path: root/tvix/nix-compat/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2024-04-10T13·33+0300
committerflokli <flokli@flokli.de>2024-04-13T10·09+0000
commit45cf7ae657086993cedaa7c72b813e319e805484 (patch)
treec4013d2072f37df7563a6dc3b3f4e4c1631cff21 /tvix/nix-compat/Cargo.toml
parent742937d55c1e156933b463312b77ca07ebd1d063 (diff)
refactor(tvix/nix-compat): move nar writer to tokio r/7898
There's little reason to keep the nar writer using Async{Read,Write}
traits from futures, while everything else async in tvix (and
nix-compat) uses tokio.

Change-Id: I8cd1efcd0dd5bb76471de997603c7b701a5095de
Reviewed-on: https://cl.tvl.fyi/c/depot/+/11391
Tested-by: BuildkiteCI
Reviewed-by: raitobezarius <tvl@lahfa.xyz>
Reviewed-by: Brian Olsen <me@griff.name>
Diffstat (limited to 'tvix/nix-compat/Cargo.toml')
-rw-r--r--tvix/nix-compat/Cargo.toml3
1 files changed, 1 insertions, 2 deletions
diff --git a/tvix/nix-compat/Cargo.toml b/tvix/nix-compat/Cargo.toml
index 8056409428..674734a0e9 100644
--- a/tvix/nix-compat/Cargo.toml
+++ b/tvix/nix-compat/Cargo.toml
@@ -5,7 +5,7 @@ edition = "2021"
 
 [features]
 # async NAR writer
-async = ["futures-util"]
+async = ["tokio"]
 # code emitting low-level packets used in the daemon protocol.
 wire = ["tokio", "pin-project-lite"]
 
@@ -16,7 +16,6 @@ data-encoding = "2.3.3"
 ed25519 = "2.2.3"
 ed25519-dalek = "2.1.0"
 enum-primitive-derive = "0.3.0"
-futures-util = { version = "0.3.30", features = ["io"], optional = true }
 glob = "0.3.0"
 nom = "7.1.3"
 num-traits = "0.2.18"