about summary refs log tree commit diff
path: root/tvix/cli/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-01-26T22·42+0100
committerclbot <clbot@tvl.fyi>2023-01-27T14·08+0000
commite3c2b3650aff8fbd4a5109cdb3406d92e9806d08 (patch)
tree060637af042dcfbdc85c02067458b85145e49e40 /tvix/cli/Cargo.toml
parenta94a1434cc2a57b330a2ad6f310573fb70e15e8a (diff)
refactor(tvix/cli): describe errors with thiserror r/5773
This is much less code, and makes it much easier to read.

Change-Id: I9028f226105f905c2cc2cabd33907ff493e26225
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7938
Reviewed-by: tazjin <tazjin@tvl.su>
Tested-by: BuildkiteCI
Autosubmit: flokli <flokli@flokli.de>
Diffstat (limited to 'tvix/cli/Cargo.toml')
-rw-r--r--tvix/cli/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/tvix/cli/Cargo.toml b/tvix/cli/Cargo.toml
index 83796855b6..56d95f7460 100644
--- a/tvix/cli/Cargo.toml
+++ b/tvix/cli/Cargo.toml
@@ -18,6 +18,7 @@ smol_str = "0.1"
 aho-corasick = "0.7"
 ssri = "7.0.0"
 data-encoding = "2.3.3"
+thiserror = "1.0.38"
 
 [dev-dependencies]
 test-case = "2.2.2"