about summary refs log tree commit diff
path: root/tvix/cli/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-05-14T18·21+0300
committerclbot <clbot@tvl.fyi>2023-05-24T16·04+0000
commit63047449d7ac5d92a50c67b5f14b0cce0da5ba81 (patch)
tree990ae774d14885297cd67b5931c0226af0d50ab1 /tvix/cli/Cargo.toml
parentad6b6b14db9c5e0a0b025687db5f387a4e6ee6a7 (diff)
feat(tvix/cli): use TvixStoreIO instead of NixCompatIO r/6193
This switches tvix-cli over from using `NixCompatIO` to `TvixStoreIO`.

For now, we simply instantiate in-memory services instead of getting
fancy with constructors inside tvix-store, but long-term, we might want
to support some URI syntax, to make this configurable at runtime.

nixpkgs eval tests might be fine (and fast!) with a purely in-memory
backend, but other usages might involve talking to a local tvix-store
over gRPC (using the gRPC client, either unix domain socket or even
further away remote), or running tvix-store in "embedded" mode (using
another client than the gRPC client).

Change-Id: I509afd3dc5ce3f2d52b0fb7067748fab820e26ab
Reviewed-on: https://cl.tvl.fyi/c/depot/+/8572
Autosubmit: flokli <flokli@flokli.de>
Reviewed-by: tazjin <tazjin@tvl.su>
Tested-by: BuildkiteCI
Diffstat (limited to 'tvix/cli/Cargo.toml')
-rw-r--r--tvix/cli/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/tvix/cli/Cargo.toml b/tvix/cli/Cargo.toml
index 1dd59a2329..676da02a07 100644
--- a/tvix/cli/Cargo.toml
+++ b/tvix/cli/Cargo.toml
@@ -9,6 +9,7 @@ path = "src/main.rs"
 
 [dependencies]
 nix-compat = { path = "../nix-compat" }
+tvix-store = { path = "../store" }
 tvix-eval = { path = "../eval" }
 rustyline = "10.0.0"
 clap = { version = "4.0", features = ["derive", "env"] }