about summary refs log tree commit diff
path: root/ops/nixos/www/cache.tvl.su.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-04-04T18·24+0200
committertazjin <mail@tazj.in>2021-04-04T18·54+0000
commit0f1d3de26f252daff8c88d62e29d08c1548e4d3e (patch)
tree00eec561072b84e76aea2730fd87d45231ef6109 /ops/nixos/www/cache.tvl.su.nix
parentaae387456a7604834d463c305d9899516ec4513c (diff)
feat(whitby): Configure nix-serve on cache.tvl.su r/2436
Having a slow cache is better than having no cache.

Change-Id: Ie3cfcd4a2937d90b0e2ad899816bc31ae806631f
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2847
Tested-by: BuildkiteCI
Reviewed-by: lukegb <lukegb@tvl.fyi>
Reviewed-by: sterni <sternenseemann@systemli.org>
Diffstat (limited to '')
-rw-r--r--ops/nixos/www/cache.tvl.su.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/ops/nixos/www/cache.tvl.su.nix b/ops/nixos/www/cache.tvl.su.nix
new file mode 100644
index 0000000000..182306bebf
--- /dev/null
+++ b/ops/nixos/www/cache.tvl.su.nix
@@ -0,0 +1,26 @@
+{ config, ... }:
+
+{
+  imports = [
+    ./base.nix
+  ];
+
+  config = {
+    services.nginx.virtualHosts."cache.tvl.su" = {
+      serverName = "cache.tvl.su";
+      serverAliases = [ "cache.tvl.fyi" ];
+      enableACME = true;
+      forceSSL = true;
+
+      extraConfig = ''
+        location = /cache-key.pub {
+          alias /etc/secrets/nix-cache-key.pub;
+        }
+
+        location / {
+          proxy_pass http://localhost:${toString config.services.nix-serve.port};
+        }
+      '';
+    };
+  };
+}